111 contact[at]joomla[dot]gr

Οδηγός αναβάθμισης από Joomla! 2.5 σε Joomla! 3.x

Αξιολόγηση Χρήστη: 0 / 5

Αστέρια ΑνενεργάΑστέρια ΑνενεργάΑστέρια ΑνενεργάΑστέρια ΑνενεργάΑστέρια Ανενεργά
 

ΒΗΜΑ 0: Να πάρετε backup!

Γνωρίζουμε βέβαια πως για τέτοιες αλλαγές ένα πράγμα είναι απολύτως απαραίτητο. Να πάρετε backup!

ΒΗΜΑ 1: Ελέγξτε αν ο διακομιστής σας υποστηρίζει τις απαιτήσεις

Πριν κάνετε οτιδήποτε, πρέπει να βεβαιωθείτε ότι ο διακομιστής φιλοξενίας σας πληροί τις προϋποθέσεις για να φιλοξενήσει μία έκδοση Joomla! 3.x. Οι τεχνικές απαιτήσεις είναι σαφέστατες και αναφέρονται σε αυτήν τη σελίδα. Αν ο διακομιστής σας δεν είναι σε θέση να φιλοξενήσει την έκδοση 3.x συζητήστε το με τον διαχειριστή του ή αλλάξτε πάροχο φιλοξενίας. Εφόσον βεβαιωθείτε λοιπόν ότι ο διακομιστής σας είναι ικανός να φιλοξενήσει την έκδοση 3.x, πηγαίνετε στο επόμενο βήμα.

ΒΗΜΑ 2: Ελέγξτε αν όλες οι επεκτάσεις είναι συμβατές με Joomla! 3.x

Για άλλη μια φορά (και καλό είναι να κρατάτε σημειώσεις του τι κάνετε σε ένα κομμάτι χαρτί, έτσι, για να θυμάστε) πριν κάνετε οτιδήποτε ακόμη, να δείτε όλες τις επεκτάσεις (πρότυπα / εφαρμογές / πρόσθετα / ενθέματα) και βεβαιωθείτε ότι οποιαδήποτε από αυτές τις επεκτάσεις είναι συμβατή με το Joomla! 3.x. Σίγουρα όταν έχετε εγκαταστήσει ένα πρότυπο στο Joomla! 2.5, το πρότυπο θα πρέπει να το αλλάξετε με ένα πρότυπο συμβατό με Joomla! 3.x. Σε γενικές γραμμές, μπορείτε να δείτε στο Joomla! Extensions Directory με αρκετή σαφήνεια αν μία επέκταση είναι συμβατή με την έκδοση 3.x. Σημείωση: μερικές φορές οι προγραμματιστές επεκτάσεων δεν ενημερώνουν το λογαριασμό τους στο JED οπότε προτείνεται ένας επιπλέον έλεγχος και στην ιστοσελίδα τους. Για παράδειγμα, στην επέκταση Xmap μπορείτε να διαπιστώσετε ότι είναι συμβατή με το Joomla! 3.x. Αν φαίνεται μόνο το εικονίδιο της έκδοσης 2.5, τότε η επέκταση δεν είναι συμβατή με το Joomla! 3.x. Αυτό σημαίνει ότι αν οπωσδήποτε σας είναι αναγκαία η επέκταση αυτή, θα πρέπει να περιμένετε έως ότου να γίνει συμβατή με το Joomla 3.x ή απλά να εγκαταστήσετε μία άλλη επέκταση που κάνει την ίδια δουλειά και είναι ήδη συμβατή με την έκδοση 3.x του Joomla!. Αυτό θα πρέπει να κάνετε και με όλες τις εγκατεστημένες επεκτάσεις σας. Κάντε μία καταγραφή τι είναι και τι δεν είναι συμβατό με το Joomla 3.x. Μόλις κάνετε αυτήν την καταγραφή, πηγαίνετε στο επόμενο βήμα.

ΒΗΜΑ 3: Αναβαθμίστε όλες τις επεκτάσεις σας σε έκδοση συμβατή με Joomla! 3.x

Αυτό είναι ένα απλό βήμα. Απλά κατεβάστε και αναβαθμίστε όλες τις επεκτάσεις σας (το Joomla! όχι ακόμη) οι οποίες είναι συμβατές με το Joomla! 3.x, εκτός από το πρότυπό σας. Απλά αναβαθμίστε κάθε επέκταση που δείχνει ότι είναι συμβατή με Joomla! 3.x. Σημείωση: Κάποιες επεκτάσεις ενώ έχουν νέες εκδόσεις, οι νέες αυτές εκδόσεις δε φαίνονται στο Joomla! οπότε μη θεωρήσετε δεδομένο ότι οποιαδήποτε επέκταση κάνετε αναβάθμιση μέσα από το Joomla! είναι και η πιο πρόσφατη. Ελέγξτε την έκδοση των εγκατεστημένων σας επεκτάσεων. Δείτε ποια έκδοση έχετε εσείς εγκατεστημένη και ποια είναι η τελευταία στη επίσημη σελίδα των κατασκευαστών τους. Μην κάνετε αναβάθμιση του προτύπου που χρησιμοποιείτε ακόμη. Δε χρειάζεται να ανησυχείτε αν δεν έχετε εγκατεστημένο προεπιλεγμένο πρότυπο. Αυτό δεν έχει να κάνει και είναι άσχετο με τη διαδικασία της αναβάθμισης. Τώρα, πηγαίνετε στο επόμενο βήμα.

ΒΗΜΑ 4: Απεγκαταστήστε όλες τις επεκτάσεις που δεν είναι συμβατές με το Joomla! 3.x

Πηγαίνετε στην περιοχή διαχείρισης. Πηγαίνετε στο «Επεκτάσεις > Διαχείριση επεκτάσεων > Διαχείριση» και επιλέξτε «Εφαρμογές». Κάντε απεγκατάσταση όποιας εφαρμογής δεν είναι συμβατή με το Joomla! 3.x. Κάνετε το ίδιο και για τα «Ενθέματα» και για τα «Πρόσθετα». Προσοχή, σίγουρα να μην απεγκαταστήσετε πράγματα που είναι του Joomla! και επίσης να μην απεγκαταστήσετε οτιδήποτε έχετε αναβαθμίσει στο βήμα 3! Σημείωση: Κάποιες επεκτάσεις ενώ στο JED δείχνει να είναι συμβατές και με Joomla! 2.5 και με Joomla! 3.x, έχουν άλλο αρχείο εγκατάστασης για κάθε έκδοση. Άλλο αρχείο για εγκατάσταση σε Joomla! 2.5 και άλλο αρχείο για εγκατάσταση σε Joomla! 3.x. Αυτές οι επεκτάσεις πρέπει να απεγκατασταθούν! Σε αυτό το βήμα θα πρέπει να θυμηθείτε να απενεργοποιήσετε το πρόσθετο «Σύστημα - Θυμήσου Με». Έχω διαβάσει στα forum ότι αν είναι ενεργοποιημένο μπορεί να δημιουργήσει προβλήματα. Τώρα, εφόσον έχετε τελειώσει, είστε έτοιμοι για τη μετάβαση στο Joomla! 3.x.

ΒΗΜΑ 5: Κάντε προεπιλεγμένη γλώσσα την Αγγλική

Πηγαίνετε στο «Επεκτάσεις > Διιαχείριση Γλωσσών» και κάντε προεπιλεγμένη γλώσσα τόσο και στην περιοχή πελατών όσο και στην περιοχή διαχείρισης την αγγλική.

ΒΗΜΑ 6: Αναβαθμίστε το Joomla! 2.5 στην έκδοση 3.x

Αυτό πρόκειται να είναι πολύ απλό. Πηγαίνετε στο «Εφαρμογές > Ενημέρωση Joomla!» και πατήστε πάνω δεξιά στο κουμπί «Επιλογές». Αλλάξτε τη ρύθμιση από «Μακροπρόθεσμη Υποστήριξη (συνιστάται)» σε «Βραχυπρόθεσμη Υποστήριξη» και αποθηκεύστε. Θα δείτε (αν όχι, κάντε μία ανανέωση τη σελίδα) ότι υπάρχει διαθέσιμη η έκδοση 3.x. Πατήστε το κουμπί «Εγκατάσταση της ενημέρωσης» και σε λίγο η ιστοσελίδα σας θα είναι σε Joomla! 3.x. Οπότε σε λίγο πρόκειται να τελειώσουμε.

ΒΗΜΑ 7: Αναβαθμίστε τις υπόλοιπες επεκτάσεις

Τώρα πλέον ενεργοποιήσετε και πάλι το πρόσθετο «Σύστημα - Θυμήσου Με». Τώρα επίσης είναι και η στιγμή που πρέπει να κάνετε εγκατάσταση το πρότυπό σας. Στο βήμα αυτό επίσης κάνετε και εγκατάσταση των εναλλακτικών επεκτάσεων, δηλαδή των επεκτάσεων που δεν ήταν συμβατές με το Joomla! 3.x και για τις οποίες έχετε βρει επεκτάσεις για να τις αντικαταστήσετε.

Πηγή